it-swarm-ru.tech

Как узнать, какую версию Linux я использую?

Есть ли способ определить, какая версия Linux (я думаю, дистрибутив и версия ядра) работает (из командной строки), которая работает в любой системе Linux?

204
Daryl Spitzer

Ядро универсально определяется с помощью uname:

$ uname -or
2.6.18-128.el5 GNU/Linux

На самом деле нет способа перекрестного распространения, чтобы определить, какой дистрибутив и версию вы используете. Были попытки сделать это непротиворечивым, но, в конце концов, оно меняется, к сожалению. Инструменты LSB предоставляют эту информацию, но по иронии судьбы не устанавливаются по умолчанию везде. Пример в системе Ubuntu 9.04 с установленным пакетом lsb-release:

$ lsb_release -irc
Distributor ID: Ubuntu
Release:        9.04
Codename:       jaunty

В противном случае ближайший широко доступный метод - проверка файлов /etc/something-release. Они существуют на большинстве распространенных платформ и на их производных (то есть Red Hat и CentOS).

Вот несколько примеров.

Ubuntu имеет /etc/lsb-release:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

Но у Debian есть /etc/debian_version:

$ cat /etc/debian_version
5.0.2

Fedora, Red Hat и CentOS имеют:

Fedora: $ cat /etc/Fedora-release
Fedora release 10 (Cambridge)

Red Hat/older CentOS: $ cat /etc/redhat-release
CentOS release 5.3 (Final)

newer CentOS: $ cat /etc/centos-release
CentOS Linux release 7.1.1503 (Core)

Gentoo:

$ cat /etc/gentoo-release
Gentoo Base System release 1.12.11.1

На данный момент у меня нет системы SUSE, но я считаю, что это /etc/SuSE-release.

Slackware имеет /etc/slackware-release и/или /etc/slackware-version.

У Mandriva есть /etc/mandriva-release.

Тогда для большинства популярных дистрибутивов

$ cat /etc/*{release,version}

будет чаще всего работать. Урезанные и пустые «серверные» установки могут не иметь установленного пакета «release» для дистрибутива.

Кроме того, две сторонние программы, которые вы можете использовать для автоматического получения этой информации: Ohai и Facter .

Обратите внимание, что во многих дистрибутивах такая информация содержится в /etc/issue или /etc/motd, но некоторые политики безопасности и лучшие практики указывают, что эти файлы должны содержать баннеры уведомлений о доступе.

Связанный: Как узнать версию программного пакета, установленного на узле? , марионетка .

264
jtimberman

Вы также можете попробовать:

$ cat /etc/issue

Обычно (хотя и не всегда) вам сообщают, какую версию вы используете. /etc/issue - это файл, используемый для экрана входа в систему.

39
Pablo Santa Cruz

Ядро: uname -a

20
raspi
cat /etc/os-release

как минимум для Ubuntu, Fedora и OpenSUSE.

Не работает для OS X по крайней мере до 10.9 (Mavericks). Вместо этого используйте sw_vers .

OpenSUSE имел cat/etc/SuSE-release до 13.1, но не рекомендуется в пользу os-release.

Redhat 6.1 имеет cat/etc/redhat-release

15
sweetfa

lsb_release -a, когда доступно, полезно.

14
CesarB

cat /proc/version нашел меня в Red Hat на общем VPS.

12
iono

Ядро: uname -r

Distro: lsb_release -a

Они будут работать на большинстве систем Linux

6
Albert Z.

Один лайнер

lsb_release -a && uname -r
5
Serge Stroobandt

Эта проблема также может быть решена с использованиемPython с модулем platform:

Использование функции platform():

python -c 'import platform; print platform.platform()'
# Linux-4.9.0-8-AMD64-x86_64-with-debian-9.6

Вышеприведенная команда возвращает одну строку, идентифицирующую базовую платформу с как можно большим количеством полезной информации.

Или используя функцию uname():

python -c 'import platform; print platform.uname()'
# ('Linux', 'debian', '4.9.0-8-AMD64', '#1 SMP Debian 4.9.130-2 (2018-10-27)', 'x86_64', '')

Вышеприведенная команда возвращает namedtuple(), содержащую шесть атрибутов: system, node, release, version, machine и processor.

Или используя функцию dist():

python -c 'import platform; print platform.dist()'
# ('debian', '9.6', '')

Последняя команда пытается определить имя имени дистрибутива ОС Linux} _, но онаустарела с Python 3.5и будет удалено в Python 3.8 .

1
simhumileco