it-swarm-ru.tech

Ваша PHP версия библиотеки MySQL отличается от вашей версии сервера MySQL

Я недавно обновил MySQL на своем сервере Debian 5.0.4 до 5.1. Теперь phpMyAdmin показывает следующее предупреждение:

Your PHP MySQL library version 5.0.51a differs from your MySQL server version 5.1.43

Это может вызвать проблемы?

14
pako

Сообщение указывает, что:

  • Вы используете версию 5.1.43 сервера MySQL
  • Но библиотека , используемая PHP для связи с этим сервером, была скомпилирована для связи с версией 5.0. х MySQL.

Теоретически, это не должно вызывать реальных проблем : второстепенные версии, как правило, совместимы; но вам может потребоваться обновить библиотеку, которая используется PHP; может быть, какой-то пакет типа "libmysql" или что-то в этом роде (у меня нет машины Debian)


Если вы хотите, чтобы это предупреждение исчезло (даже если я не уверен, что оно действительно может вызвать большие проблемы) , вам придется обновить компонент PHP , который используется для связи с MySQL.
Примечание. С зависимостями может быть не так просто обновить один пакет ...

Я бы сказал, что вам нужно обновить что-то вроде php5-mysql; что значит :

apt-get install php5-mysql

(Согласно на этой странице - среди прочего - чтобы обновить один пакет, вы должны использовать install)

Если вы используете aptitude, а не apt-get ... Не уверены в правильности выбора, который следует использовать для обновления только одного пакета; Тем не менее, aptitude safe-upgrade должен представить вам список пакетов, которые он будет обновлять, что позволит вам решить, хотите ли вы продолжить ...


Но вы сказали в комментарии к другому ответу, что Debian поставляется по умолчанию с MySQL 5.0, что означает, что "официальный" модуль для PHP, вероятно, скомпилирован с libmysql 5.0, а не с libmysql 5.1 ,.

Чтобы решить эту проблему, вам нужно:

  • Найдите репозиторий, который предоставляет PHP (или, по крайней мере, расширение mysql) , скомпилированный с libmysql 5.1
  • Или перекомпилируйте PHP и ​​/ или расширение mysql для версии libmysql, которая в настоящее время используется в вашей системе - то есть libmysql 5,1
23
Pascal MARTIN

Попробуйте запустить Sudo apt-get update mysql-client.

0
Mark C

Я видел это в консоли phpMyAdmin - я запускаю Debian 8 в облаке Google и недавно обновил до mysql 5.7.21. Мне пришлось запустить PHP NativeDriver, чтобы заставить это спадать

Sudo apt-get update
Sudo apt-get install php5-mysqlnd
0
DropHit