it-swarm-ru.tech

Как указать минимальную версию Ruby в gemspec?

Я пишу gemspec для новой версии gem, которая теперь требует Ruby 1.9. Предыдущие версии гема были в порядке с Ruby 1.8, но теперь потребуется 1.9. Есть ли способ вызвать сбой установки гема для этой версии гема с предупреждением для пользователей, которые пытаются установить его на Ruby 1.8?

52
dan

Из документация RubyGems :

# This gem will work with 1.8.6 or greater...
spec.required_Ruby_version = '>= 1.8.6'

# Only with Ruby 2.0.x
spec.required_Ruby_version = '~> 2.0'
81
rausch